齐乐分享

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 101|回复: 0
收起左侧

易语言获取本机在线QQ

[复制链接]
齐乐分享网 发表于 2020-5-25 00:22:04 | 显示全部楼层 |阅读模式
调用 精易模块

原理:通过枚举QQ通用窗口类名   

  1. .版本 2
  2. .支持库 spec

  3. .子程序 获取本机登陆QQ, 整数型, , 返回的QQ号数量
  4. .参数 QQ号码, 文本型, 参考 数组, 返回的QQ号数组
  5. .局部变量 局_窗口信息, 精易_窗口信息, , "0"
  6. .局部变量 局_QQ, 文本型
  7. .局部变量 局_i, 整数型

  8. 清除数组 (QQ号码)
  9. .计次循环首 (窗口_枚举 (局_窗口信息), 局_i)
  10.     调试输出 (局_窗口信息 [局_i].窗口类名)
  11.     .如果真 (到大写 (局_窗口信息 [局_i].窗口类名) = “5B3838F5-0C81-46D9-A4C0-6EA28CA3E942”)
  12.         加入成员 (QQ号码, 取文本右边 (局_窗口信息 [局_i].窗口标题, 取文本长度 (局_窗口信息 [局_i].窗口标题) - 倒找文本 (局_窗口信息 [局_i].窗口标题, “_”, , 假)))
  13.     .如果真结束

  14. .计次循环尾 ()
  15. 数组_反转 (QQ号码)
  16. 返回 (取数组成员数 (QQ号码))
复制代码



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

发布主题 上个主题 下个主题 快速回复 收藏帖子 返回列表 搜索
小黑屋|sitemap| |站点统计

版权所有:齐乐分享—技术交流,学习,分享平台 ( 皖ICP备14022669号-1 )

技术支持:Powered by Discuz! X3.4 Copyright © 2013-2018 Comsenz Inc. All Rights Reserved

GMT+8, 2022-5-17 16:23 , Processed in 0.080765 second(s), 8 queries , Gzip On, MemCache On.

快速回复 返回顶部 返回列表